FLO30 Rear Hub not catching

FLO Product Support, FAQ, Cycling, Triathlon, Etc.

FLO30 Rear Hub not catching

Postby jcarey » July 12th, 2014, 1:41 pm

Hi Guys,

I brought a pair of FLO30 10 months ago and today the free hub didn't engage, luckily near the end of a ride. I've tried to see what the problem is but I didn't want to go to far in case I invalidate the warranty. All I have done is remove the cassette and end caps. I then didn't know how to remove the free hub body, I was hoping at this stage it would just pull off but to no avail.

Should I tried to remove the free hub body to see what is going on with the free hub body pawls? If so how do I remove the free hub body? Do you have any other suggestions.

Kind Regards

Jamie Carey
jcarey
 
Posts: 4
Joined: October 29th, 2013, 3:17 pm

Re: FLO30 Rear Hub not catching

Postby Radioactive Man » July 21st, 2014, 3:03 pm

Get two 5mm allen keys and undo the end caps they are never very tight. Then you will be able to just pull the free hub off by hand easy. I would be interested in seeing what has happened to your free hub as mine (bearings in free hub) is stuffed after only 3 months riding and this is after I lubed it up extra after 3 weeks cause of noise under load! The free hub seems a weak point on these wheels from my experience they just don't lube it enough in the factory.
Radioactive Man
 
Posts: 8
Joined: April 9th, 2014, 4:43 am

Re: FLO30 Rear Hub not catching

Postby jcarey » July 21st, 2014, 3:36 pm

Thanks for you reply Radioactive Man. I had done what you suggested but the hub didn't come off, I was too timid to use any force as I don't want to void the warranty if I make a mistake. I think I read somewhere there is a 2 year warranty and my wheels are less than a year like yours. What did FLO say about your issue, was it covered under their warranty?

Can you suggest a way that I can prise the hub off without damaging it?
jcarey
 
Posts: 4
Joined: October 29th, 2013, 3:17 pm

Re: FLO30 Rear Hub not catching

Postby Radioactive Man » July 23rd, 2014, 4:26 am

Wow if it is that hard to get off with the end cap removed obviously, you may have a broken pawl or something jamming it up. It should be very easy to slide it off once the end cap is removed!
Radioactive Man
 
Posts: 8
Joined: April 9th, 2014, 4:43 am

Re: FLO30 Rear Hub not catching

Postby jcarey » July 23rd, 2014, 3:34 pm

Hi Radioactive Man, I noticed another post of yours asking flo for a free hub, what come of this? Did they send you one and was it covered under their warranty.
jcarey
 
Posts: 4
Joined: October 29th, 2013, 3:17 pm

Re: FLO30 Rear Hub not catching

Postby Radioactive Man » July 29th, 2014, 3:56 pm

They said they would send me a new one as the bearings had failed very rough in mine!
Radioactive Man
 
Posts: 8
Joined: April 9th, 2014, 4:43 am


Return to General Discussion

Who is online

Users browsing this forum: No registered users and 0 guests